Personal tools
You are here: Home / LBN / Up2date / Core Linux / BastionLinux 25 / chef15-15.5.9-1.lbn25.noarch

chef15-15.5.9-1.lbn25.noarch

Package Attributes
RPM  chef15-15.5.9-1.lbn25.noarch.rpm Architecture  noarch Size  5456884 Created  2019/11/17 04:08:43 UTC
Package Specification
Summary Client libraries for the Chef systems integration framework
Group System Enviornment/Base
License ASL 2.0
Home Page http://wiki.opscode.com/display/chef
Description

Chef is a systems integration framework and configuration management library written in Ruby. Chef provides a Ruby library and API that can be used to bring the benefits of configuration management to an entire infrastructure.

Chef can be run as a client (chef-client) to a server, or run as a standalone tool (chef-solo). Configuration recipes are written in a pure Ruby DSL.

Requires
(rubygem(ed25519) >= 1.2 with rubygem(ed25519) < 2)  
rpmlib(RichDependencies)  
(rubygem(bcrypt_pbkdf) >= 1.0 with rubygem(bcrypt_pbkdf) < 2)  
rpmlib(CompressedFileNames)  
(rubygem(syslog-logger) >= 1.6 with rubygem(syslog-logger) < 2)  
(rubygem(net-sftp) >= 2.1 with rubygem(net-sftp) < 3 with rubygem(net-sftp) >= 2.1.2)  
(rubygem(erubis) >= 2.7 with rubygem(erubis) < 3)  
(rubygem(mixlib-authentication) >= 2.1 with rubygem(mixlib-authentication) < 4)  
rpmlib(PayloadIsXz)  
(rubygem(diff-lcs) >= 1.2 with rubygem(diff-lcs) < 2 with rubygem(diff-lcs) >= 1.2.4)  
rpmlib(PayloadFilesHavePrefix)  
(rubygem(net-ssh-multi) >= 1.2 with rubygem(net-ssh-multi) < 2 with rubygem(net-ssh-multi) >= 1.2.1)  
(rubygem(net-ssh) >= 4.2 with rubygem(net-ssh) < 6)  
(rubygem(train-core) >= 3.1 with rubygem(train-core) < 4)  
(rubygem(ohai) >= 15.0 with rubygem(ohai) < 16)  
(rubygem(mixlib-log) >= 2.0.3 with rubygem(mixlib-log) < 4.0)  
(rubygem(mixlib-archive) >= 0.4 with rubygem(mixlib-archive) < 2.0)  
rpmlib(FileDigests)  
(rubygem(iniparse) >= 1.4 with rubygem(iniparse) < 2)  
(rubygem(uuidtools) >= 2.1.5 with rubygem(uuidtools) < 2.2)  
(rubygem(mixlib-cli) >= 2.1.1 with rubygem(mixlib-cli) < 3.0)  
(rubygem(ffi-yajl) >= 2.2 with rubygem(ffi-yajl) < 3)  
(rubygem(tty-screen) >= 0.6 with rubygem(tty-screen) < 1)  
(rubygem(mixlib-shellout) >= 3.0.3 with rubygem(mixlib-shellout) < 4.0)  
(rubygem(plist) >= 3.2 with rubygem(plist) < 4)  
(rubygem(proxifier) >= 1.0 with rubygem(proxifier) < 2)  
(rubygem(license-acceptance) >= 1.0 with rubygem(license-acceptance) < 2 with rubygem(license-acceptance) >= 1.0.5)  
(rubygem(ffi) >= 1.9 with rubygem(ffi) < 2 with rubygem(ffi) >= 1.9.25)  
Provides
chef15
rubygem(chef)
rubygem(chef)
rubygem-chef
Obsoletes
chef11
chef12
chef13
chef14

Document Actions